Load Error: ''wrong game DLL API version'' - please help

Post any questions, suggestions, complaints or feedback in here, read news about the forum and site here. (We may or may not answer..)

Please post any question about the game in the Edge of Chaos specific forums
SnareDevil
Waking up in Chronos
Posts: 1
Joined: Mon May 02, 2011 9:50 am

Load Error: ''wrong game DLL API version'' - please help

Postby SnareDevil » Mon May 02, 2011 9:57 am

Hi I'm getting this error in the load screen, ""wrong game DLL API version"".

As you can see from the log below, it seems to be loading then suddenly wants to shutdown.

I'm running version 1.3 of Doom.

Can anyone help please?

using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Games\Doom 3\eoc\game00.pk4/gamex86.dll
copy gamex86.dll to C:\Games\Doom 3\eoc\gamex86.dll
0 0 1360 768
Regenerated world, staticAllocCount = 0.
Shutting down sound hardware
idRenderSystem::Shutdown()
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...shutting down QGL
...unloading OpenGL DLL
wrong game DLL API version

deadite4
Site Admin
Posts: 654
Joined: Fri Aug 07, 2009 2:58 pm
Location: Any Town, USA
Contact:

Re: Load Error: ''wrong game DLL API version'' - please help

Postby deadite4 » Mon May 02, 2011 12:24 pm

That's an easy one :)

You need Doom 3 v1.3.1
Sounds Great. Do it again.

jeffreymorgan.info
Waking up in Chronos
Posts: 2
Joined: Mon Aug 29, 2011 10:54 pm

Re: Load Error: ''wrong game DLL API version'' - please help

Postby jeffreymorgan.info » Mon Aug 29, 2011 11:01 pm

I get the same error message and I've been running version 1.3.1302 for years:

using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Program Files\Doom 3\eoc\game00.pk4/gamex86.dll
copy gamex86.dll to C:\Program Files\Doom 3\eoc\gamex86.dll
0 0 1280 1024
Regenerated world, staticAllocCount = 0.
Shutting down sound hardware
idRenderSystem::Shutdown()
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...shutting down QGL
...unloading OpenGL DLL
wrong game DLL API version

deadite4
Site Admin
Posts: 654
Joined: Fri Aug 07, 2009 2:58 pm
Location: Any Town, USA
Contact:

Re: Load Error: ''wrong game DLL API version'' - please help

Postby deadite4 » Tue Aug 30, 2011 6:09 pm

I get the same error message and I've been running version 1.3.1302 for years:


That's your problem ;) . Doom 3 v1.3.1 is technically 1.3.1304. You are running Doom 3 1.3 which in the console is 1.3.1302!
Sounds Great. Do it again.

jeffreymorgan.info
Waking up in Chronos
Posts: 2
Joined: Mon Aug 29, 2011 10:54 pm

Re: Load Error: ''wrong game DLL API version'' - please help

Postby jeffreymorgan.info » Tue Aug 30, 2011 10:20 pm

Thank you, much appreciated; now it runs like a charm--and thanks for the conversion!

Serves me right for clicking on 'Updates' and believing the message: "Doom 3 is up to date. No updates are required"!

For anyone who needs the final update like I did, go here and pick your OS:

ftp://ftp.idsoftware.com/idstuff/doom3/

Thanks again!

jeffreymorgan.info


Return to “Questions, Suggestions and Feedback (About the site)”

Who is online

Users browsing this forum: No registered users and 1 guest